[How To] Generic TvHeadend Server Setup for Freeview NZ




Links

  • tv_grab URL: http://files.matthuisman.nz/tv_grab_nz-py
  • Freeview Frequencies (remember to pick the correct location on the left of the table)

Buy my recommended USB Tuner

Comments

  1. Hi, I'm trying to get TVheadend working on OSMC (RPi 3), should I use this guide, or your LibreELEC one?

    ReplyDelete
    Replies
    1. Umm. This one. However, you will need to work out how to install TvHeadend in OSMC first :)
      There are a few forum posts on how-to do it :)
      Once you have TvHeadend running - hopefully you can just follow along to this.

      Delete
    2. I think you can install it from the "OSMC AppStore"

      Delete
    3. Thanks, I used this guide and have got TVheadend working and channels coming through. I'm struggling to get the EPG data loaded though. OSMC uses TVH 4.0.9 which looks different to 4.2 so I can't follow your guide exactly. I have your internal grabber module installed and selected in TVH but it either doesn't run, or runs but something else isn't working. TVH 4.0.9 doesn't have an option to manually run the internal grabber in the GUI. Any ideas?

      Delete
    4. OK, I have managed to get something working... somehow... using some combination of your grabber and tv_grab_file. I have no idea whether the EPG I have working is a one-off data load, or whether it is going to update each day, but for now all channels have working data. I guess I'll find out in a few days if the EPG data is refreshing regularly or not.

      Delete
    5. Great to hear Ashton.
      Let me know how it goes.
      I may need to do an OSMC video as well :)

      Delete
  2. Does this method require a usb to dvb adapter?

    ReplyDelete
  3. You sir, are a god among men. I've been using TVHeadend for a couple years now and I've just accepted the epg wasn't going to work in kodi the way I wanted. Last time I attempted to set up a grabber was just before Duke launched. As a result my epg has been half working since. Stumbled onto your blog after finding your OnDemand plugins browsing the forums just looking for a tweak or 2. All I need now is a workaround for lightbox in libreelec/linux and life is complete!

    ReplyDelete
  4. An OSMC video would be perfect :) TVH 4.0.9 looks a bit different so I had to guess a few things but I think it all worked. I have no idea about ongoing guide data refresh though so I'll post back when I know if that's working or not. TVH documentation is pretty sparse on how it's all supposed to work together.

    ReplyDelete
    Replies
    1. Pretty sure you can install later version just via terminal...
      I'll have a play around in next few days :)

      Delete
  5. OK, looks like everything is working! Guide data is refreshing, and I checked the logs with journalctl and I can see your grabber firing when it is supposed to. In the end there were only a couple of minor GUI differences between your video and the required setup on OSMC. Thanks again!

    ReplyDelete
  6. Hi Matt, I need a xml file for the grabber on my shield, could point me in right direction please?

    ReplyDelete
    Replies
    1. http://files.matthuisman.nz/freeview.xml
      or
      http://files.matthuisman.nz/freeview.xml.gz (Gzipped)

      Hope that helps :)

      Delete
    2. Thanks will try it out. What's the benefit to using this file as opposed to the ota data?

      Delete
    3. I'm not 100% on that.
      I haven't tried the OTA in a while.
      It used to not work very well.
      I think they have been working on it lately though so it may have been improved.

      Delete
  7. Yes last night playing around trying to set it up (not knowing anything about it all really) I opend it up in kodi and it seemed the epg data worked ok for the brief time I tried it. No logos or anything though.
    I did notice a change in the epg grabber part of tvheadend compared to your video, I am missing the EPG grabber modules tab.
    I had some trouble trying to scan to get the channels (in the Waikato - Tearoha) and I still dont have choice or prime working. Sometimes they would scan and fail and sometimes pass (or partial). One question, do I have each frequency set to 8mhz? Thats what I have kind of working at the moment, it previously had 7mhz entered in there.

    ReplyDelete
    Replies
    1. Yes. Bandwidth should be 8MHz for all NZ freeview.
      You may be using an older version of TvHeadend?
      I'm using 4.1 in the video.

      Prime and Choice are on the Kordia mux.
      Which should be 594MHz in your area.

      Delete
    2. I have noticed that Kordia signal is a lot weaker here in Chch.
      Choice and Prime are the most fussy.
      Make sure your using a good UHF aerial optimized for Horizontal.

      Delete
    3. Thanks mate, yea i can get them both fine on my tv, maybe just running them through the usb tuner is a bit flakey. Will have a play around with it. It should be the latest TvHeadend as a guy in the nvidia shield community has just made it an apk to run on the shield in the 3 or 4 weeks.

      Delete
    4. I also have a Shield.
      Can you link to this APK / any info about it?
      I'd be interested to take a look.

      also, you might need to change "User interface level" to "Expert" under "Configuration -> Base"

      Delete
  8. https://forums.geforce.com/default/topic/1000226/shield-tv/tvheadend-apk-the-easy-way-to-run-tvheadend-on-the-shield-/1/

    I have flashed Lexyan build on about page 6 or 7 to the shield to allow use of a PS3 playtv usb tuner, and using the TvHeadend end apk in the first post.

    ReplyDelete
    Replies
    1. Thanks so much for that xml file, have it all working pretty good, choice and prime are working sometimes. Your video and help has been awesome, cheers!

      Delete
    2. Hey Matt would you know why I am not getting HGTV, it in the first tab list of channels but isn't in the next tab. Also no epg for choice tv, would the weak signal affect the EPG?

      Delete
    3. Select HGTV in Services Tab and select "Map Selected"
      It should now appear under Channels Tab.

      You can view the XML file that it uses here:
      http://files.matthuisman.nz/freeview.xml

      Choice has ID: freeviewnz.37
      You can search for "freeviewnz.37" in the XML and notice there are plenty of listings.

      So, make sure your Choice Channel has the correct EPG Source selected.

      And check listings in the EPG on the WebUI to confirm if things are working or not (not in KODI)

      Delete
    4. Weak signal will not affect EPG as this is downloaded via the internet.

      Delete
  9. Thanks, got HGTV into the channel list, EPG working although channel not playing yet.. Checked the Choice EPG and it is set correctly but still not working for some reason. Also Prime EPG hardly working, does say whats playing and whats next but no more info than that.
    I might have a play with the aerial cable, or try the other tuner in the Playtv as signal isnt the best. Rarley get Choice or Prime playing, and sometimes it takes a couple of goes to get some of the other channels playing. Once they are playing there is no problem. I notice when switching channels in kodi by pressing the next button usually it says no signal, but if I stop the channel then select next channel from the menu it will work.

    ReplyDelete
  10. If anyone wants a local source for a RTL USB TV tuner I have now done two installs following the above instructions with no issues using this model from Trademe:

    https://www.trademe.co.nz/1306910895

    A few dollars more than an overseas option but shipping is much faster :)

    ReplyDelete
  11. Hi Matt, very interested in what you've got running on the Pi with Openelect but just wondering if this is all possible with a windows system with Kodi 17 on it (Win 7 64bit running Kodi 17). I believe I have the right USB dvb stick needed with the RTl2832U R820T combination. So, it is possible?
    Thanks for any help
    Gary

    ReplyDelete

Post a Comment